Anna, Melissa, VA outage

Incident Report for Grayson Collin Communications

Resolved

All repairs have been completed and connectivity restored.
Posted Jun 04, 2026 - 14:49 CDT

Monitoring

All residential service should be restored. We are monitoring the situation.
Posted Jun 04, 2026 - 13:15 CDT

Update

Fiber repair is still ongoing, ETR is approximately 4 hours.
Posted Jun 04, 2026 - 12:16 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 04, 2026 - 11:59 CDT

Update

Some areas of Anna and Van Alstyne are back online, crews are still working on the repair for the fiber damage with no ETR at this time.
Posted Jun 04, 2026 - 10:52 CDT

Identified

We have located the fiber cut in South Sherman and crews are onsite assessing the damage. No ETR at this time.
Posted Jun 04, 2026 - 09:18 CDT

Investigating

We are currently investigating an outage affecting Anna, Melissa, and parts of Van Alstyne, crews are en route to troubleshoot. No ETR at this time.
Posted Jun 04, 2026 - 08:29 CDT
This incident affected: Internet Services.