The outage that the storms caused last night has been repaired and all services are back online. If your service does not come back up after the maintenance is performed, please follow the steps provided on this link Click Here. If your service remains down after following the steps provided at the previous link, please contact our customer service department between the hours of 8:00 am. and 5:00 pm. at (903) 482-7000 or email your outage to customerservice@graysoncollin.net and we will get you taken care of as quickly as possible.
Posted Sep 22, 2025 - 17:18 CDT
Update
The outage that the storms caused last night has been repaired and all services are back online. If your service does not come back up after the maintenance is performed, please follow the steps provided on this link Click Here. If your service remains down after following the steps provided at the previous link, please contact our customer service department between the hours of 8:00 am. and 5:00 pm. at (903) 482-7000 or email your outage to customerservice@graysoncollin.net and we will get you taken care of as quickly as possible.
Posted Sep 22, 2025 - 17:17 CDT
Update
Electric crews have given us the all-clear to begin repairs to the fiber network that will attach to the poles replaced due to last night’s storms. The repairs should be completed by approximately 6:00 pm. Thank you again for your patience as we rebuild a portion of the network.
Posted Sep 22, 2025 - 15:43 CDT
Update
Last night’s strong storms damaged many poles between Howe and Tom Bean. Electric crews have worked through the night to replace poles and begin the process of placing new wire. New poles have been set and crews are working to place the new wire. As soon as the electric crews are finished and it is safe to do so, fiber will be placed on the new poles. Some of the existing fiber can be hung, however a portion of the line was damaged and will need to be replaced. As soon as we have an estimated time of repair we will pass it along. We appreciate your patience as we work to repair the damage caused by this dangerous storm.
Posted Sep 22, 2025 - 08:52 CDT
Update
There were widespread outages due to the storms and crews will be out early in the morning to assess and repair damages. Grayson-Collin Electric Cooperative has reported that some electrical poles are down affecting power in the area. For more information check the following link GCEC Power Outage
Posted Sep 21, 2025 - 22:01 CDT
Update
Grayson-Collin Electric Cooperative has reported that some electrical poles are down affecting power in the area. For more information check the following link GCEC Power Outage.
Posted Sep 21, 2025 - 19:50 CDT
Identified
Power outages in the area due to the weather may be impacting internet and phone services. Please check main power and GFCI outlets.
Posted Sep 21, 2025 - 19:00 CDT
Update
Power outages in the area due to the weather may be impacting internet and phone services. Please check main power and GFCI outlets.
Posted Sep 21, 2025 - 18:59 CDT
Investigating
Power outages in the area due to the weather may be impacting internet and phone services. Please check main power and GFCI outlets.
Posted Sep 21, 2025 - 18:59 CDT
This incident affected: Internet Services and Phone Voice Services.